Cross-site scripting in katello
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
A cross-site scripting (XSS) flaw was found in the katello component of Satellite. An attacker with privilege to create/edit organizations and locations is able to execute a XSS attacks against other users through the Subscriptions or the Red Hat Repositories wizards. This can possibly lead to malicious code execution and extraction of the anti-CSRF token of higher privileged users. Versions before 3.9.0 are vulnerable.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| The Katello Project | katello | 3.9.0 | — | No fix listed | CNA |
| — | katello (RubyGems) | before 3.9.0 | 3.9.0 | Patch available | GHSA-mhhc-r88h-2qrm |
- katello VendorThe Katello Project Affected 3.9.0 Fixed in — No fix listed CNA
- katello (RubyGems) Vendor— Affected before 3.9.0 Fixed in 3.9.0 Patch available GHSA-mhhc-r88h-2qrm
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:satellite:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:a:theforeman:katello:*:*:*:*:*:*:*:* | before 3.9.0 | Vulnerable | The Foreman Project |
- cpe:2.3:a:redhat:satellite:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:a:theforeman:katello:*:*:*:*:*:*:*:* Versions before 3.9.0 Vulnerable ·The Foreman Project
Remediation
- Fix · GHSA-mhhc-r88h-2qrm katello (RubyGems) Fixed in 3.9.0 Advisory →
Red Hat 1 advisory
- RHSA-2019:1222 Released 2019-05-14 · Red Hat rating ModerateSatellite 6.5 Release
- Red Hat Satellite 6.5 SOAPpy-0.11.6-17.el7, ansiblerole-insights-client-1.6-1.el7sat, candlepin-2.5.15-1.el7sat +47
- Red Hat Satellite Capsule 6.5 SOAPpy-0.11.6-17.el7, ansiblerole-insights-client-1.6-1.el7sat, createrepo_c-0.7.4-1.el7sat +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 6.5 | Fixed | RHSA-2019:1222 |
| Red Hat Satellite Capsule 6.5 | Fixed | RHSA-2019:1222 |
Not affected: 1 product
- Red Hat Subscription Asset Manager
Timeline
- 2026-10-02 Threatist record created from CVE-2018-16887
- 2026-10-03 Alias added: GHSA-mhhc-r88h-2qrm
References
More The Katello Project vulnerabilities
- TI-2024-04484 Katello: potential cross-site scripting exploit in ui CVSS 3.1MEDIUM 4.8
Sources
- CVE-2018-16887 · CVE Program
- CVE-2018-16887 · NVD
- FIRST EPSS
- GHSA-mhhc-r88h-2qrm · GitHub Advisory Database · CC BY 4.0
- CVE-2018-16887 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences