An issue was discovered in Elefant CMS before 2.0.7.
Priority MEDIUM 48CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
An issue was discovered in Elefant CMS before 2.0.7. There is a PHP Code Execution Vulnerability in /designer/add/stylesheet.php by using a .php extension in the New Stylesheet Name field in conjunction with <?php content, because of insufficient input validation in apps/designer/handlers/csspreview.php.
Why it matters now
EPSS 0.03727 89th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed elefant/cms (Packagist): 2.0.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | elefant/cms (Packagist) | before 2.0.7 | 2.0.7 | Patch available | GHSA-x2w2-qgv6-8xrm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- elefant/cms (Packagist) Vendor— Affected before 2.0.7 Fixed in 2.0.7 Patch available GHSA-x2w2-qgv6-8xrm
Remediation
- Fix · GHSA-x2w2-qgv6-8xrm elefant/cms (Packagist) Fixed in 2.0.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-16975
- 2026-10-03 Alias added: GHSA-x2w2-qgv6-8xrm
References
More Elefant vulnerabilities
- TI-2018-12125 An issue was discovered in Elefant CMS before 2.0.7. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2018-16975 · CVE Program
- CVE-2018-16975 · NVD
- FIRST EPSS
- GHSA-x2w2-qgv6-8xrm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences