Read the docs
TI-2018-12513 Aliases CVE-2018-17567GHSA-4xjh-m3qx-49wc

Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to…

Priority LOW 37CWE-59Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-59 and the CVSS impact.

Summary

Jekyll through 3.6.2, 3.7.x through 3.7.3, and 3.8.x through 3.8.3 allows attackers to access arbitrary files by specifying a symlink in the "include" key in the "_config.yml" file.

Why it matters now

EPSS 0.02188 82nd percentileScored 2026-11-07
Fix Fixed jekyll (RubyGems): 3.6.3, 3.7.4, 3.8.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—jekyll (RubyGems)before 3.6.33.6.3Patch availableGHSA-4xjh-m3qx-49wc
—jekyll (RubyGems)3.7.0 to before 3.7.43.7.4Patch availableGHSA-4xjh-m3qx-49wc
—jekyll (RubyGems)3.8.0 to before 3.8.43.8.4Patch availableGHSA-4xjh-m3qx-49wc
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • jekyll (RubyGems) Vendor— Affected before 3.6.3 Fixed in 3.6.3 Patch available GHSA-4xjh-m3qx-49wc
  • jekyll (RubyGems) Vendor— Affected 3.7.0 to before 3.7.4 Fixed in 3.7.4 Patch available GHSA-4xjh-m3qx-49wc
  • jekyll (RubyGems) Vendor— Affected 3.8.0 to before 3.8.4 Fixed in 3.8.4 Patch available GHSA-4xjh-m3qx-49wc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jekyllrb:jekyll:*:*:*:*:*:*:*:*up to 3.6.2; 3.7.0 – 3.7.3; 3.8.0 – 3.8.3VulnerableJekyllrb
  • cpe:2.3:a:jekyllrb:jekyll:*:*:*:*:*:*:*:* Versions up to 3.6.2; 3.7.0 – 3.7.3; 3.8.0 – 3.8.3 Vulnerable ·Jekyllrb

Remediation

  • Fix · GHSA-4xjh-m3qx-49wc jekyll (RubyGems) Fixed in 3.6.3 Advisory →
  • Fix · GHSA-4xjh-m3qx-49wc jekyll (RubyGems) Fixed in 3.7.4 Advisory →
  • Fix · GHSA-4xjh-m3qx-49wc jekyll (RubyGems) Fixed in 3.8.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-17567
  2. 2026-10-03 Alias added: GHSA-4xjh-m3qx-49wc

References

Sources