An issue was discovered in YMFE YApi 1.3.23.
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An issue was discovered in YMFE YApi 1.3.23. There is stored XSS in the name field of a project.
Why it matters now
EPSS 0.00667 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed yapi-vendor (npm): 1.3.23
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | yapi-vendor (npm) | before 1.3.23 | 1.3.23 | Patch available | GHSA-5xgh-643p-cp2g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- yapi-vendor (npm) Vendor— Affected before 1.3.23 Fixed in 1.3.23 Patch available GHSA-5xgh-643p-cp2g
Remediation
- Fix · GHSA-5xgh-643p-cp2g yapi-vendor (npm) Fixed in 1.3.23 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-17574
- 2026-10-03 Alias added: GHSA-5xgh-643p-cp2g
References
More Ymfe Yapi vulnerabilities
- TI-2021-14834 Cross Site Scripting (XSS) vulnerability in yapi 1.9.1 allows attackers to execute… CVSS 3.1MEDIUM 5.4
- TI-2025-43010 An issue pertaining to CWE-400: Uncontrolled Resource Consumption was discovered in YMFE… CVSS 3.1HIGH 7.5
- TI-2025-43009 An issue pertaining to CWE-295: Improper Certificate Validation was discovered in YMFE… CVSS 3.1HIGH 7.4
- TI-2025-43011 An issue pertaining to CWE-79: Improper Neutralization of Input During Web Page… CVSS 3.1MEDIUM 5.4
- TI-2021-09224 Weak JSON Web Token (JWT) signing secret generation in YMFE YApi through 1.9.2 allows… CVSS 3.1MEDIUM 5.1
Sources
- CVE-2018-17574 · CVE Program
- CVE-2018-17574 · NVD
- FIRST EPSS
- GHSA-5xgh-643p-cp2g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences