crowbar provision leaks admin password to all nodes in cleartext
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
An Improper Privilege Management in crowbar of SUSE OpenStack Cloud 7, SUSE OpenStack Cloud 8, SUSE OpenStack Cloud 9, SUSE OpenStack Cloud Crowbar 8, SUSE OpenStack Cloud Crowbar 9 allows root users on any crowbar managed node to cause become root on any other node. This issue affects: SUSE OpenStack Cloud 7 crowbar-core versions prior to 4.0+git.1578392992.fabfd186c-9.63.1, crowbar-. SUSE OpenStack Cloud 8 ardana-cinder versions prior to 8.0+git.1579279939.ee7da88-3.39.3, ardana-. SUSE OpenStack Cloud 9 ardana-ansible versions prior to 9.0+git.1581611758.f694f7d-3.16.1, ardana-. SUSE OpenStack Cloud Crowbar 8 crowbar-core versions prior to 5.0+git.1582968668.1a55c77c5-3.35.4, crowbar-. SUSE OpenStack Cloud Crowbar 9 crowbar-core versions prior to 6.0+git.1582892022.cbd70e833-3.19.3, crowbar-.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE OpenStack Cloud 7 | crowbar-core to before 4.0+git.1578392992.fabfd186c-9.63.1, crowbar- | 4.0+git.1578392992.fabfd186c-9.63.1, crowbar- | Patch available | CNA |
| SUSE | SUSE OpenStack Cloud 8 | ardana-cinder to before 8.0+git.1579279939.ee7da88-3.39.3, ardana- | 8.0+git.1579279939.ee7da88-3.39.3, ardana- | Patch available | CNA |
| SUSE | SUSE OpenStack Cloud 9 | ardana-ansible to before 9.0+git.1581611758.f694f7d-3.16.1, ardana- | 9.0+git.1581611758.f694f7d-3.16.1, ardana- | Patch available | CNA |
| SUSE | SUSE OpenStack Cloud Crowbar 8 | crowbar-core to before 5.0+git.1582968668.1a55c77c5-3.35.4, crowbar- | 5.0+git.1582968668.1a55c77c5-3.35.4, crowbar- | Patch available | CNA |
| SUSE | SUSE OpenStack Cloud Crowbar 9 | crowbar-core to before 6.0+git.1582892022.cbd70e833-3.19.3, crowbar- | 6.0+git.1582892022.cbd70e833-3.19.3, crowbar- | Patch available | CNA |
- SUSE OpenStack Cloud 7 VendorSUSE Affected crowbar-core to before 4.0+git.1578392992.fabfd186c-9.63.1, crowbar- Fixed in 4.0+git.1578392992.fabfd186c-9.63.1, crowbar- Patch available CNA
- SUSE OpenStack Cloud 8 VendorSUSE Affected ardana-cinder to before 8.0+git.1579279939.ee7da88-3.39.3, ardana- Fixed in 8.0+git.1579279939.ee7da88-3.39.3, ardana- Patch available CNA
- SUSE OpenStack Cloud 9 VendorSUSE Affected ardana-ansible to before 9.0+git.1581611758.f694f7d-3.16.1, ardana- Fixed in 9.0+git.1581611758.f694f7d-3.16.1, ardana- Patch available CNA
- SUSE OpenStack Cloud Crowbar 8 VendorSUSE Affected crowbar-core to before 5.0+git.1582968668.1a55c77c5-3.35.4, crowbar- Fixed in 5.0+git.1582968668.1a55c77c5-3.35.4, crowbar- Patch available CNA
- SUSE OpenStack Cloud Crowbar 9 VendorSUSE Affected crowbar-core to before 6.0+git.1582892022.cbd70e833-3.19.3, crowbar- Fixed in 6.0+git.1582892022.cbd70e833-3.19.3, crowbar- Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:suse:openstack_cloud:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | SUSE |
| cpe:2.3:a:suse:openstack_cloud:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | SUSE |
| cpe:2.3:a:suse:openstack_cloud:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | SUSE |
| cpe:2.3:a:suse:openstack_cloud_crowbar:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | SUSE |
| cpe:2.3:a:suse:openstack_cloud_crowbar:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | SUSE |
- cpe:2.3:a:suse:openstack_cloud:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·SUSE
- cpe:2.3:a:suse:openstack_cloud:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·SUSE
- cpe:2.3:a:suse:openstack_cloud:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·SUSE
- cpe:2.3:a:suse:openstack_cloud_crowbar:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·SUSE
- cpe:2.3:a:suse:openstack_cloud_crowbar:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·SUSE
Remediation
- Fix · CNA SUSE OpenStack Cloud 7 (SUSE) Fixed in 4.0+git.1578392992.fabfd186c-9.63.1, crowbar-
- Fix · CNA SUSE OpenStack Cloud 8 (SUSE) Fixed in 8.0+git.1579279939.ee7da88-3.39.3, ardana-
- Fix · CNA SUSE OpenStack Cloud 9 (SUSE) Fixed in 9.0+git.1581611758.f694f7d-3.16.1, ardana-
- Fix · CNA SUSE OpenStack Cloud Crowbar 8 (SUSE) Fixed in 5.0+git.1582968668.1a55c77c5-3.35.4, crowbar-
- Fix · CNA SUSE OpenStack Cloud Crowbar 9 (SUSE) Fixed in 6.0+git.1582892022.cbd70e833-3.19.3, crowbar-
Timeline
- 2026-10-02 Threatist record created from CVE-2018-17954
- 2026-10-03 Alias added: GHSA-m786-w84g-pcv9
References
More SUSE Openstack Cloud vulnerabilities
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2016-03148 The (1) HTTP and (2) FTP coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1… KEVCVSS 3.1MEDIUM 5.5
- TI-2016-03145 The EPHEMERAL coder in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allows remote… KEVCVSS 3.1MEDIUM 5.5
- TI-2017-13226 The tcpmss_mangle_packet function in net/netfilter/xt_TCPMSS.c in the Linux kernel before… CVSS 3.1CRITICAL 9.8
- TI-2016-01179 named in ISC BIND 9.x before 9.9.8-P4 and 9.10.x before 9.10.3-P4 allows remote attackers… CVSS 3.1HIGH 8.6
Sources
- CVE-2018-17954 · CVE Program
- CVE-2018-17954 · NVD
- FIRST EPSS
- GHSA-m786-w84g-pcv9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences