An issue was discovered in BageCMS 3.1.3.
Priority MEDIUM 45CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-94.
Summary
An issue was discovered in BageCMS 3.1.3. The attacker can execute arbitrary PHP code on the web server and can read any file on the web server via an index.php?r=admini/template/updateTpl&filename= URI.
Why it matters now
EPSS 0.01489 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-18258
- 2026-10-03 Alias added: GHSA-wqcf-q92w-mcgr
References
More Bagesoft Bagecms vulnerabilities
- TI-2018-13858 BageCMS 3.1.3 has CSRF via upload/index.php?r=admini/admin/ownerUpdate to modify a user account. CVSS 3.0HIGH 8.8
- TI-2018-13543 In BageCMS 3.1.3, upload/index.php has a CSRF vulnerability that can be used to upload… CVSS 3.0HIGH 8.8
- TI-2018-10450 index.php?r=admini/admin/create in BageCMS V3.1.3 allows CSRF to add a background administrator account. CVSS 3.0HIGH 8.8
- TI-2018-12905 An issue was discovered in BageCMS 3.1.3. CVSS 3.0HIGH 7.5
- TI-2019-06040 upload/protected/modules/admini/views/post/index.php in BageCMS through 3.1.4 allows SQL… CVSS 3.0HIGH 7.2
- TI-2023-18788 A stored cross-site scripting (XSS) vulnerability in Bagecms v3.1.0 allows attackers to… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2018-18258 · CVE Program
- CVE-2018-18258 · NVD
- FIRST EPSS
- GHSA-wqcf-q92w-mcgr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences