Asciidoctor in versions < 1.5.8 allows remote attackers to cause a denial of service…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-835.
Summary
Asciidoctor in versions < 1.5.8 allows remote attackers to cause a denial of service (infinite loop). The loop was caused by the fact that Parser.next_block was not exhausting all the lines in the reader as the while loop expected it would. This was happening because the regular expression that detects any list was not agreeing with the regular expression that detects a specific list type. So the line kept getting pushed back onto the reader, hence causing the loop.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | asciidoctor (RubyGems) | before 1.5.8 | 1.5.8 | Patch available | GHSA-qc9p-mjxm-j2wj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- asciidoctor (RubyGems) Vendor— Affected before 1.5.8 Fixed in 1.5.8 Patch available GHSA-qc9p-mjxm-j2wj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:asciidoctor:asciidoctor:*:*:*:*:*:*:*:* | before 1.5.8 | Vulnerable | Asciidoctor |
- cpe:2.3:a:asciidoctor:asciidoctor:*:*:*:*:*:*:*:* Versions before 1.5.8 Vulnerable ·Asciidoctor
Remediation
- Fix · GHSA-qc9p-mjxm-j2wj asciidoctor (RubyGems) Fixed in 1.5.8 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Virtualization 4 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-18385
- 2026-10-03 Alias added: GHSA-qc9p-mjxm-j2wj
References
Sources
- CVE-2018-18385 · CVE Program
- CVE-2018-18385 · NVD
- FIRST EPSS
- GHSA-qc9p-mjxm-j2wj · GitHub Advisory Database · CC BY 4.0
- CVE-2018-18385 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences