An issue was discovered in libpg_query 10-1.0.2.
Priority LOW 31CWE-772Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-772.
Summary
An issue was discovered in libpg_query 10-1.0.2. There is a memory leak in pg_query_raw_parse in pg_query_parse.c, which might lead to a denial of service.
Why it matters now
EPSS 0.0116 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pg-query (PyPI): 0.28pglast (PyPI): 0.28
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pg-query (PyPI) | before 0.28 | 0.28 | Patch available | GHSA-vm3q-58wm-2r2x |
| — | pglast (PyPI) | before 0.28 | 0.28 | Patch available | GHSA-vm3q-58wm-2r2x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pg-query (PyPI) Vendor— Affected before 0.28 Fixed in 0.28 Patch available GHSA-vm3q-58wm-2r2x
- pglast (PyPI) Vendor— Affected before 0.28 Fixed in 0.28 Patch available GHSA-vm3q-58wm-2r2x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libpg_query_project:libpg_query:10-1.0.2:*:*:*:*:*:*:* | 10-1.0.2 | Vulnerable | Libpg Query Project |
- cpe:2.3:a:libpg_query_project:libpg_query:10-1.0.2:*:*:*:*:*:*:* Versions 10-1.0.2 Vulnerable ·Libpg Query Project
Remediation
- Fix · GHSA-vm3q-58wm-2r2x pg-query (PyPI) Fixed in 0.28 Advisory →
- Fix · GHSA-vm3q-58wm-2r2x pglast (PyPI) Fixed in 0.28 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-18482
- 2026-10-03 Alias added: GHSA-vm3q-58wm-2r2x
References
Sources
- CVE-2018-18482 · CVE Program
- CVE-2018-18482 · NVD
- FIRST EPSS
- GHSA-vm3q-58wm-2r2x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences