Read the docs
TI-2018-13920 Aliases CVE-2018-19639GHSA-82r4-3q2m-qgrm

Code execution if run with command line switch -v

Priority LOW 35CWE-78Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-78.

Summary

If supportutils before version 3.1-5.7.1 is run with -v to perform rpm verification and the attacker manages to manipulate the rpm listing (e.g. with CVE-2018-19638) he can execute arbitrary commands as root.

Why it matters now

EPSS 0.00503 43rd percentileScored 2026-11-07
Fix Fixed supportutils (SUSE): 3.1-5.7.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
SUSEsupportutilsbefore 3.1-5.7.13.1-5.7.1Patch availableCNA
  • supportutils VendorSUSE Affected before 3.1-5.7.1 Fixed in 3.1-5.7.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opensuse:supportutils:*:*:*:*:*:*:*:*before 3.1-5.7.1VulnerableopenSUSE
  • cpe:2.3:a:opensuse:supportutils:*:*:*:*:*:*:*:* Versions before 3.1-5.7.1 Vulnerable ·openSUSE

Remediation

  • Fix · CNA supportutils (SUSE) Fixed in 3.1-5.7.1

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    SUSE supportutils — openSUSE-SU-2019:1351

    5 records Highest priority Priority LOW 5 LOW

    Other records, highest priority first

    • TI-2018-13917 Local root exploit via inclusion of attacker controlled shell scriptPriority LOW 34
    • TI-2018-13921 Code execution if run with command line switch -vPriority LOW 25
    • TI-2018-13918 Static temporary filename allows overwriting of filesPriority LOW 25

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-19639
  2. 2026-10-03 Alias added: GHSA-82r4-3q2m-qgrm

References

  • TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
  • TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
  • TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
  • TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
  • TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
  • TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
See all 1331 →

Sources