Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.
Summary
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | swagger-ui (npm) | before 4.1.3 | 4.1.3 | Patch available | GHSA-cr3q-pqgq-m8c2 |
| — | org.webjars:swagger-ui (Maven) | before 4.1.3 | 4.1.3 | Patch available | GHSA-cr3q-pqgq-m8c2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- swagger-ui (npm) Vendor— Affected before 4.1.3 Fixed in 4.1.3 Patch available GHSA-cr3q-pqgq-m8c2
- org.webjars:swagger-ui (Maven) Vendor— Affected before 4.1.3 Fixed in 4.1.3 Patch available GHSA-cr3q-pqgq-m8c2
Remediation
- Fix · GHSA-cr3q-pqgq-m8c2 swagger-ui (npm) Fixed in 4.1.3 Advisory →
- Fix · GHSA-cr3q-pqgq-m8c2 org.webjars:swagger-ui (Maven) Fixed in 4.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-25031
- 2026-10-03 Alias added: GHSA-cr3q-pqgq-m8c2
References
Advisory 3
More SMARTBEAR Swagger Ui vulnerabilities
- TI-2019-13041 A Cascading Style Sheets (CSS) injection vulnerability in Swagger UI before 3.23.11… CVSS 3.1CRITICAL 9.8
- TI-2024-14800 Default swagger-ui configuration exposes all files in the module CVSS 3.1MEDIUM 5.3
Sources
- CVE-2018-25031 · CVE Program
- CVE-2018-25031 · NVD
- FIRST EPSS
- GHSA-cr3q-pqgq-m8c2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences