ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1…
Priority LOW 37CWE-125Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
Why it matters now
EPSS 0.01067 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed admesh (PyPI): 0.98.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | admesh (PyPI) | before 0.98.5 | 0.98.5 | Patch available | GHSA-5jrq-582v-9767 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- admesh (PyPI) Vendor— Affected before 0.98.5 Fixed in 0.98.5 Patch available GHSA-5jrq-582v-9767
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:admesh_project:admesh:*:*:*:*:*:*:*:* | up to 0.98.4 | Vulnerable | Admesh Project |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:admesh_project:admesh:*:*:*:*:*:*:*:* Versions up to 0.98.4 Vulnerable ·Admesh Project
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-5jrq-582v-9767 admesh (PyPI) Fixed in 0.98.5 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-25033
- 2026-10-03 Alias added: GHSA-5jrq-582v-9767
References
Advisory 3
Sources
- CVE-2018-25033 · CVE Program
- CVE-2018-25033 · NVD
- FIRST EPSS
- GHSA-5jrq-582v-9767 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-25033 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences