In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS.
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.
Why it matters now
EPSS 0.011 65th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed smarty/smarty (Packagist): 3.1.47, 4.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | smarty/smarty (Packagist) | before 3.1.47 | 3.1.47 | Patch available | GHSA-hwq7-5vv9-c6cf |
| — | smarty/smarty (Packagist) | 4.0.0 to before 4.2.1 | 4.2.1 | Patch available | GHSA-hwq7-5vv9-c6cf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- smarty/smarty (Packagist) Vendor— Affected before 3.1.47 Fixed in 3.1.47 Patch available GHSA-hwq7-5vv9-c6cf
- smarty/smarty (Packagist) Vendor— Affected 4.0.0 to before 4.2.1 Fixed in 4.2.1 Patch available GHSA-hwq7-5vv9-c6cf
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:smarty:smarty:*:*:*:*:*:*:*:* | before 3.1.47; 4.0.0 to before 4.2.1 | Vulnerable | smarty-php |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:smarty:smarty:*:*:*:*:*:*:*:* Versions before 3.1.47; 4.0.0 to before 4.2.1 Vulnerable ·smarty-php
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-hwq7-5vv9-c6cf smarty/smarty (Packagist) Fixed in 3.1.47 Advisory →
- Fix · GHSA-hwq7-5vv9-c6cf smarty/smarty (Packagist) Fixed in 4.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-25047
- 2026-10-03 Alias added: GHSA-hwq7-5vv9-c6cf
References
Advisory 4
Other 6
- https://github.com/smarty-php/smarty/releases/tag/v4.2.1
- https://github.com/smarty-php/smarty/releases/tag/v3.1.47
- https://github.com/smarty-php/smarty/commit/55ea25d1f50f0406fb1ccedd212c527977793fc9
- https://github.com/FriendsOfPHP/security-advisories/blob/master/smarty/smarty/CVE-2018-25047.yaml
- https://github.com/smarty-php/smarty
- https://lists.debian.org/debian-lts-announce/2024/11/msg00013.html
Sources
- CVE-2018-25047 · CVE Program
- CVE-2018-25047 · NVD
- FIRST EPSS
- GHSA-hwq7-5vv9-c6cf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences