Harvest Chosen abstract-chosen.coffee AbstractChosen cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability, which was classified as problematic, has been found in Harvest Chosen up to 1.8.6. Affected by this issue is the function AbstractChosen of the file coffee/lib/abstract-chosen.coffee. The manipulation of the argument group_label leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.8.7 is able to address this issue. The name of the patch is 77fd031d541e77510268d1041ed37798fdd1017e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216956.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Harvest | Chosen | 1.8.0; 1.8.1; 1.8.2; 1.8.3; 1.8.4; 1.8.5; 1.8.6 | — | No fix listed | CNA |
| — | harvesthq/chosen (Packagist) | before 1.8.7 | 1.8.7 | Patch available | GHSA-x5q4-m45m-fm94 |
- Chosen VendorHarvest Affected 1.8.0; 1.8.1; 1.8.2; 1.8.3; 1.8.4; 1.8.5; 1.8.6 Fixed in — No fix listed CNA
- harvesthq/chosen (Packagist) Vendor— Affected before 1.8.7 Fixed in 1.8.7 Patch available GHSA-x5q4-m45m-fm94
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:getharvest:chosen:*:*:*:*:*:*:*:* | before 1.8.7 | Vulnerable | Getharvest |
- cpe:2.3:a:getharvest:chosen:*:*:*:*:*:*:*:* Versions before 1.8.7 Vulnerable ·Getharvest
Remediation
- Fix · GHSA-x5q4-m45m-fm94 harvesthq/chosen (Packagist) Fixed in 1.8.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-25050
- 2026-10-03 Alias added: GHSA-x5q4-m45m-fm94
- 2026-10-28 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2018-25050 · CVE Program
- CVE-2018-25050 · NVD
- FIRST EPSS
- GHSA-x5q4-m45m-fm94 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences