FarCry Solr Pro Plugin Search solrProSearch.cfc cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability was found in FarCry Solr Pro Plugin up to 1.5.x. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file packages/forms/solrProSearch.cfc of the component Search Handler. The manipulation of the argument suggestion leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.6.0 is able to address this issue. The name of the patch is b8f3d61511c9b02b781ec442bfb803cbff8e08d5. It is recommended to upgrade the affected component. The identifier VDB-216961 was assigned to this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | FarCry Solr Pro Plugin | 1.0; 1.1; 1.2; 1.3; 1.4; 1.5 | — | No fix listed | CNA |
- FarCry Solr Pro Plugin Vendor— Affected 1.0; 1.1; 1.2; 1.3; 1.4; 1.5 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:farcry_solr_pro_project:farcry_solr_pro:*:*:*:*:*:*:*:* | up to 1.5.0 | Vulnerable | Farcry Solr Pro Project |
- cpe:2.3:a:farcry_solr_pro_project:farcry_solr_pro:*:*:*:*:*:*:*:* Versions up to 1.5.0 Vulnerable ·Farcry Solr Pro Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-25055
- 2026-10-03 Alias added: GHSA-2gpx-vh9j-9x8j
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2018-25055 · CVE Program
- CVE-2018-25055 · NVD
- FIRST EPSS
- GHSA-2gpx-vh9j-9x8j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences