Blue Yonder postgraas_server PostgreSQL Backend postgres_cluster_driver.py create_postgres_db sql injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
A vulnerability, which was classified as critical, was found in Blue Yonder postgraas_server up to 2.0.0b2. Affected is the function _create_pg_connection/create_postgres_db of the file postgraas_server/backends/postgres_cluster/postgres_cluster_driver.py of the component PostgreSQL Backend Handler. The manipulation leads to sql injection. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 7cd8d016edc74a78af0d81c948bfafbcc93c937c. It is recommended to upgrade the affected component. VDB-234246 is the identifier assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Blue Yonder | postgraas_server | 2.0.0b2 | — | No fix listed | CNA |
| — | postgraas-server (PyPI) | before 2.0.0 | 2.0.0 | Patch available | GHSA-vghm-8cjp-hjw6 |
- postgraas_server VendorBlue Yonder Affected 2.0.0b2 Fixed in — No fix listed CNA
- postgraas-server (PyPI) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-vghm-8cjp-hjw6
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:blueyonder:postgraas_server:*:*:*:*:*:*:*:* | before 2.0.0 | Vulnerable | Blue Yonder |
| cpe:2.3:a:blueyonder:postgraas_server:2.0.0:beta1:*:*:*:*:*:* | 2.0.0 beta1 | Vulnerable | Blue Yonder |
| cpe:2.3:a:blueyonder:postgraas_server:2.0.0:beta2:*:*:*:*:*:* | 2.0.0 beta2 | Vulnerable | Blue Yonder |
- cpe:2.3:a:blueyonder:postgraas_server:*:*:*:*:*:*:*:* Versions before 2.0.0 Vulnerable ·Blue Yonder
- cpe:2.3:a:blueyonder:postgraas_server:2.0.0:beta1:*:*:*:*:*:* Versions 2.0.0 beta1 Vulnerable ·Blue Yonder
- cpe:2.3:a:blueyonder:postgraas_server:2.0.0:beta2:*:*:*:*:*:* Versions 2.0.0 beta2 Vulnerable ·Blue Yonder
Remediation
- Fix · GHSA-vghm-8cjp-hjw6 postgraas-server (PyPI) Fixed in 2.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-25088
- 2026-10-03 Alias added: GHSA-vghm-8cjp-hjw6
References
Sources
- CVE-2018-25088 · CVE Program
- CVE-2018-25088 · NVD
- FIRST EPSS
- GHSA-vghm-8cjp-hjw6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences