Nagios XI < 5.5.7 Privilege Escalation via MRTG Graphing Component
Priority LOW 39CWE-250Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-250.
Summary
Nagios XI versions prior to 5.5.7 contain a privilege escalation vulnerability in the MRTG graphing component. MRTG-related processes/scripts executed with excessive privileges, allowing a local attacker with limited system access to abuse file/command execution paths or writable resources to gain elevated privileges.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00348 28th percentileScored 2026-11-07
Fix Fixed XI (Nagios): 5.5.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA XI (Nagios) Fixed in 5.5.7
Timeline
- 2026-10-02 Threatist record created from CVE-2018-25123
- 2026-10-03 Alias added: GHSA-cg42-mqc9-9fhp
References
More Nagios Xi vulnerabilities
- TI-2021-07545 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2021-07544 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2021-07543 Nagios XI version xi-5.7.5 is affected by OS command injection. KEVCVSS 3.1HIGH 8.8
- TI-2019-11993 Nagios XI before 5.6.6 allows remote command execution as root. KEVCVSS 3.1HIGH 8.8
- TI-2023-26027 Nagios XI before version 5.11.3 was discovered to contain a remote code execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2018-11196 Snoopy 1.0 in Nagios XI 5.5.6 allows remote unauthenticated attackers to execute… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2018-25123 · CVE Program
- CVE-2018-25123 · NVD
- FIRST EPSS
- GHSA-cg42-mqc9-9fhp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences