Read the docs
TI-2018-15582 Aliases CVE-2018-25357GHSA-hxmh-2xc4-c894

Dolibarr ERP CRM 7.0.3 Remote Code Execution via install/step1.php

Priority HIGH 81CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Dolibarr ERP CRM 7.0.3 contains a remote code execution vulnerability that allows unauthenticated attackers to execute arbitrary code by injecting PHP code through the db_name parameter. Attackers can send a POST request to install/step1.php with malicious PHP code in the db_name parameter, then execute commands via the check.php endpoint using the cmd GET parameter.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01701 77th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed dolibarr/dolibarr (Packagist): 7.0.4, 6.0.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DolibarrDolibarr ERP CRMup to 7.0.3—No fix listedCNA
—dolibarr/dolibarr (Packagist)7.0.0 to before 7.0.47.0.4Patch availableGHSA-hxmh-2xc4-c894
—dolibarr/dolibarr (Packagist)before 6.0.86.0.8Patch availableGHSA-hxmh-2xc4-c894
  • Dolibarr ERP CRM VendorDolibarr Affected up to 7.0.3 Fixed in — No fix listed CNA
  • dolibarr/dolibarr (Packagist) Vendor— Affected 7.0.0 to before 7.0.4 Fixed in 7.0.4 Patch available GHSA-hxmh-2xc4-c894
  • dolibarr/dolibarr (Packagist) Vendor— Affected before 6.0.8 Fixed in 6.0.8 Patch available GHSA-hxmh-2xc4-c894

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:dolibarr:dolibarr_erp\/crm:*:*:*:*:*:*:*:*up to 7.0.3VulnerableDolibarr
  • cpe:2.3:a:dolibarr:dolibarr_erp\/crm:*:*:*:*:*:*:*:* Versions up to 7.0.3 Vulnerable ·Dolibarr

Remediation

  • Fix · GHSA-hxmh-2xc4-c894 dolibarr/dolibarr (Packagist) Fixed in 7.0.4 Advisory →
  • Fix · GHSA-hxmh-2xc4-c894 dolibarr/dolibarr (Packagist) Fixed in 6.0.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-25357
  2. 2026-10-03 Alias added: GHSA-hxmh-2xc4-c894

References

  • TI-2022-21049 Dolibarr Open Source ERP & CRM for Business before v14.0.1 allows attackers to escalate privileges via a crafted API. CVSS 3.1CRITICAL 9.8
  • TI-2022-03742 SQL Injection in dolibarr/dolibarr CVSS 3.1CRITICAL 9.8
  • TI-2023-14191 Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an… CVSS 3.1HIGH 8.8
  • TI-2019-15505 Dolibarr ERP/CRM 10.0.1 SQL Injection via elemid CVSS 4.0HIGH 8.8
  • TI-2026-18933 Dolibarr: OS Command Injection (RCE) via MAIN_ODT_AS_PDF configuration CVSS 4.0CRITICAL 9.4
  • TI-2023-20161 Cross Site Scripting vulnerability in Dolibarr ERP CRM v.17.0.1 and before allows a… CVSS 3.1CRITICAL 9.6
See all 110 →

Sources