Jenkins Release Plugin 2.9 and earlier did not require form submissions to be submitted…
Priority MEDIUM 40CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Jenkins Release Plugin 2.9 and earlier did not require form submissions to be submitted via POST, resulting in a CSRF vulnerability allowing attackers to trigger release builds.
Why it matters now
EPSS 0.01019 63rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:release (Maven): 2.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:release (Maven) | before 2.10 | 2.10 | Patch available | GHSA-j2h6-j34w-g5vp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:release (Maven) Vendor— Affected before 2.10 Fixed in 2.10 Patch available GHSA-j2h6-j34w-g5vp
Remediation
- Fix · GHSA-j2h6-j34w-g5vp org.jenkins-ci.plugins:release (Maven) Fixed in 2.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000013
- 2026-10-03 Alias added: GHSA-j2h6-j34w-g5vp
References
More Jenkins Release vulnerabilities
- TI-2020-02169 Cross-site scripting in Jenkins Release Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2018-1000013 · CVE Program
- CVE-2018-1000013 · NVD
- FIRST EPSS
- GHSA-j2h6-j34w-g5vp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences