The Squid Software Foundation Squid HTTP Caching Proxy version 3.0 to 3.5.27, 4.0 to…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 4 fixed, 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat.
Summary
The Squid Software Foundation Squid HTTP Caching Proxy version 3.0 to 3.5.27, 4.0 to 4.0.22 contains a Incorrect Pointer Handling vulnerability in ESI Response Processing that can result in Denial of Service for all clients using the proxy.. This attack appear to be exploitable via Remote server delivers an HTTP response payload containing valid but unusual ESI syntax.. This vulnerability appears to have been fixed in 4.0.23 and later.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:squid-cache:squid:*:*:*:*:*:*:*:* | 3.0 – 3.5.27; 4.0 – 4.0.22 | Vulnerable | squid-cache |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* | 17.10 | Vulnerable | Canonical |
- cpe:2.3:a:squid-cache:squid:*:*:*:*:*:*:*:* Versions 3.0 – 3.5.27; 4.0 – 4.0.22 Vulnerable ·squid-cache
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* Versions 17.10 Vulnerable ·Canonical
Remediation
Red Hat 1 advisory
- RHSA-2020:1068 Released 2020-03-31 · Red Hat rating Moderatesquid security and bug fix update
- Red Hat Enterprise Linux Server (v. 7) squid-7:3.5.20-15.el7, squid-migration-script-7:3.5.20-15.el7
- Red Hat Enterprise Linux Server Optional (v. 7) squid-sysvinit-7:3.5.20-15.el7
- Red Hat Enterprise Linux Workstation (v. 7) squid-7:3.5.20-15.el7, squid-migration-script-7:3.5.20-15.el7
- Red Hat Enterprise Linux Workstation Optional (v. 7) squid-sysvinit-7:3.5.20-15.el7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2020:1068 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2020:1068 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2020:1068 |
| Red Hat Enterprise Linux Workstation Optional (v. 7) | Fixed | RHSA-2020:1068 |
Not affected: 2 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000024
- 2026-10-03 Alias added: GHSA-gh8j-c69q-gf38
References
Sources
- CVE-2018-1000024 · CVE Program
- CVE-2018-1000024 · NVD
- FIRST EPSS
- GHSA-gh8j-c69q-gf38 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000024 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences