Read the docs

Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect…

Priority LOW 38CWE-732Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect Access Control vulnerability in src/Firebase/Auth/IdTokenVerifier.php does not verify for token signature that can result in JWT with any email address and user ID could be forged from an actual token, or from thin air. This attack appear to be exploitable via Attacker would only need to know email address of the victim on most cases.. This vulnerability appears to have been fixed in 3.8.1.

Why it matters now

EPSS 0.0131 70th percentileScored 2026-11-07
Fix Fixed kreait/firebase-php (Packagist): 3.8.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—kreait/firebase-php (Packagist)3.2.0 to before 3.8.13.8.1Patch availableGHSA-4gjj-r7w8-42cq
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • kreait/firebase-php (Packagist) Vendor— Affected 3.2.0 to before 3.8.1 Fixed in 3.8.1 Patch available GHSA-4gjj-r7w8-42cq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:firebase_admin_sdk_for_php_project:firebase_admin_sdk_for_php:*:*:*:*:*:*:*:*3.2.0 – 3.8.0VulnerableFirebase Admin Sdk For Php Project

Remediation

  • Fix · GHSA-4gjj-r7w8-42cq kreait/firebase-php (Packagist) Fixed in 3.8.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000025
  2. 2026-10-03 Alias added: GHSA-4gjj-r7w8-42cq

References

Sources