Read the docs

Jenkins Pipeline: Supporting APIs Plugin 2.17 and earlier have an arbitrary code…

Priority MEDIUM 43CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-502.

Summary

Jenkins Pipeline: Supporting APIs Plugin 2.17 and earlier have an arbitrary code execution due to incomplete sandbox protection: Methods related to Java deserialization like readResolve implemented in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.

Why it matters now

EPSS 0.02567 85th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins.workflow:workflow-support (Maven): 2.18Red Hat: 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.plugins.workflow:workflow-support (Maven)before 2.182.18Patch availableGHSA-p3g4-9xfv-wq9v
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins.workflow:workflow-support (Maven) Vendor— Affected before 2.18 Fixed in 2.18 Patch available GHSA-p3g4-9xfv-wq9v

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:pipeline_supporting_apis:*:*:*:*:*:jenkins:*:*up to 2.17VulnerableJenkins
  • cpe:2.3:a:jenkins:pipeline_supporting_apis:*:*:*:*:*:jenkins:*:* Versions up to 2.17 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-p3g4-9xfv-wq9v org.jenkins-ci.plugins.workflow:workflow-support (Maven) Fixed in 2.18 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Enterprise 3AffectedNo fix planned: Will not fix

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000058
  2. 2026-10-03 Alias added: GHSA-p3g4-9xfv-wq9v

References

Sources