An improper authorization vulnerability exists in Jenkins versions 2.106 and earlier, and…
Priority LOW 27CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-918 and the CVSS impact.
Summary
An improper authorization vulnerability exists in Jenkins versions 2.106 and earlier, and LTS 2.89.3 and earlier, that allows an attacker to have Jenkins submit HTTP GET requests and get limited information about the response.
Why it matters now
EPSS 0.01699 77th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.89.4, 2.107Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.89.4 | 2.89.4 | Patch available | GHSA-6mv9-hcx5-7mhh |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.90 to before 2.107 | 2.107 | Patch available | GHSA-6mv9-hcx5-7mhh |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.89.4 Fixed in 2.89.4 Patch available GHSA-6mv9-hcx5-7mhh
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.90 to before 2.107 Fixed in 2.107 Patch available GHSA-6mv9-hcx5-7mhh
CPE configurations NVD · 3
Remediation
- Fix · GHSA-6mv9-hcx5-7mhh org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.89.4 Advisory →
- Fix · GHSA-6mv9-hcx5-7mhh org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.107 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000067
- 2026-10-03 Alias added: GHSA-6mv9-hcx5-7mhh
References
Advisory 2
Sources
- CVE-2018-1000067 · CVE Program
- CVE-2018-1000067 · NVD
- FIRST EPSS
- GHSA-6mv9-hcx5-7mhh · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000067 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences