Read the docs

NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross ite Request…

Priority MEDIUM 40CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross ite Request Forgery (CSRF) vulnerability in Pym.js _onNavigateToMessage function. https://github.com/nprapps/pym.js/blob/master/src/pym.js#L573 that can result in Arbitrary javascript code execution. This attack appear to be exploitable via Attacker gains full javascript access to pages with Pym.js embeds when user visits an attacker crafted page.. This vulnerability appears to have been fixed in versions 1.3.2 and later.

Why it matters now

EPSS 0.01005 63rd percentileScored 2026-11-07
Fix Fixed pym.js (npm): 1.3.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—pym.js (npm)0.4.2 to before 1.3.21.3.2Patch availableGHSA-82gw-pqf7-q3j2
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • pym.js (npm) Vendor— Affected 0.4.2 to before 1.3.2 Fixed in 1.3.2 Patch available GHSA-82gw-pqf7-q3j2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:npr:pym.js:*:*:*:*:*:*:*:*0.4.2 – 1.3.1VulnerableNpr
  • cpe:2.3:a:npr:pym.js:*:*:*:*:*:*:*:* Versions 0.4.2 – 1.3.1 Vulnerable ·Npr

Remediation

  • Fix · GHSA-82gw-pqf7-q3j2 pym.js (npm) Fixed in 1.3.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000086
  2. 2026-10-03 Alias added: GHSA-82gw-pqf7-q3j2

References

Sources