A cross-site scripting vulnerability exists in Jenkins CppNCSS Plugin 1.1 and earlier in…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A cross-site scripting vulnerability exists in Jenkins CppNCSS Plugin 1.1 and earlier in AbstractProjectAction/index.jelly that allow an attacker to craft links to Jenkins URLs that run arbitrary JavaScript in the user's browser when accessed.
Why it matters now
EPSS 0.00827 57th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:cppncss (Maven): 1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:cppncss (Maven) | before 1.2 | 1.2 | Patch available | GHSA-xgmh-rvpw-6498 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:cppncss (Maven) Vendor— Affected before 1.2 Fixed in 1.2 Patch available GHSA-xgmh-rvpw-6498
Remediation
- Fix · GHSA-xgmh-rvpw-6498 org.jenkins-ci.plugins:cppncss (Maven) Fixed in 1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000108
- 2026-10-03 Alias added: GHSA-xgmh-rvpw-6498
References
Sources
- CVE-2018-1000108 · CVE Program
- CVE-2018-1000108 · NVD
- FIRST EPSS
- GHSA-xgmh-rvpw-6498 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences