A cross-site scripting vulnerability exists in Jenkins TestLink Plugin 2.12 and earlier…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A cross-site scripting vulnerability exists in Jenkins TestLink Plugin 2.12 and earlier in TestLinkBuildAction/summary.jelly and others that allow an attacker who can control e.g. TestLink report names to have Jenkins serve arbitrary HTML and JavaScript
Why it matters now
EPSS 0.00705 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:testlink (Maven): 2.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:testlink (Maven) | before 2.13 | 2.13 | Patch available | GHSA-3rrg-p8xc-3457 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:testlink (Maven) Vendor— Affected before 2.13 Fixed in 2.13 Patch available GHSA-3rrg-p8xc-3457
Remediation
- Fix · GHSA-3rrg-p8xc-3457 org.jenkins-ci.plugins:testlink (Maven) Fixed in 2.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000113
- 2026-10-03 Alias added: GHSA-3rrg-p8xc-3457
References
More Jenkins Testlink vulnerabilities
- TI-2019-07687 Insufficiently protected credentials in Jenkins TestLink Plugin CVSS 3.1MEDIUM 5.3
Sources
- CVE-2018-1000113 · CVE Program
- CVE-2018-1000113 · NVD
- FIRST EPSS
- GHSA-3rrg-p8xc-3457 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences