nmap version 6.49BETA6 through 7.60, up to and including SVN revision 37147 contains a…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
nmap version 6.49BETA6 through 7.60, up to and including SVN revision 37147 contains a Directory Traversal vulnerability in NSE script http-fetch that can result in file overwrite as the user is running it. This attack appears to be exploitable via a victim that runs NSE script http-fetch against a malicious web site. This vulnerability appears to have been fixed in 7.7.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nmap:nmap:6.49:beta6:*:*:*:*:*:* | 6.49 beta6 | Vulnerable | Nmap |
| cpe:2.3:a:nmap:nmap:7.00:*:*:*:*:*:*:* | 7.00 | Vulnerable | Nmap |
| cpe:2.3:a:nmap:nmap:7.01:*:*:*:*:*:*:* | 7.01 | Vulnerable | Nmap |
| cpe:2.3:a:nmap:nmap:7.10:*:*:*:*:*:*:* | 7.10 | Vulnerable | Nmap |
| cpe:2.3:a:nmap:nmap:7.11:*:*:*:*:*:*:* | 7.11 | Vulnerable | Nmap |
| cpe:2.3:a:nmap:nmap:7.12:*:*:*:*:*:*:* | 7.12 | Vulnerable | Nmap |
| cpe:2.3:a:nmap:nmap:7.25:beta1:*:*:*:*:*:* | 7.25 beta1 | Vulnerable | Nmap |
| cpe:2.3:a:nmap:nmap:7.25:beta2:*:*:*:*:*:* | 7.25 beta2 | Vulnerable | Nmap |
| cpe:2.3:a:nmap:nmap:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | Nmap |
| cpe:2.3:a:nmap:nmap:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | Nmap |
- cpe:2.3:a:nmap:nmap:6.49:beta6:*:*:*:*:*:* Versions 6.49 beta6 Vulnerable ·Nmap
- cpe:2.3:a:nmap:nmap:7.00:*:*:*:*:*:*:* Versions 7.00 Vulnerable ·Nmap
- cpe:2.3:a:nmap:nmap:7.01:*:*:*:*:*:*:* Versions 7.01 Vulnerable ·Nmap
- cpe:2.3:a:nmap:nmap:7.10:*:*:*:*:*:*:* Versions 7.10 Vulnerable ·Nmap
- cpe:2.3:a:nmap:nmap:7.11:*:*:*:*:*:*:* Versions 7.11 Vulnerable ·Nmap
- cpe:2.3:a:nmap:nmap:7.12:*:*:*:*:*:*:* Versions 7.12 Vulnerable ·Nmap
- cpe:2.3:a:nmap:nmap:7.25:beta1:*:*:*:*:*:* Versions 7.25 beta1 Vulnerable ·Nmap
- cpe:2.3:a:nmap:nmap:7.25:beta2:*:*:*:*:*:* Versions 7.25 beta2 Vulnerable ·Nmap
- cpe:2.3:a:nmap:nmap:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·Nmap
- cpe:2.3:a:nmap:nmap:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·Nmap
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000161
- 2026-10-03 Alias added: GHSA-463f-727w-pqp7
References
Advisory 1
More Nmap vulnerabilities
- TI-2026-41812 Nmap - Integer Underflow in IPv6 Extension Header Parsing CVSS 4.0MEDIUM 6.9
- TI-2018-10857 Nmap through 7.70, when the -sV option is used, allows remote attackers to cause a denial… CVSS 3.0HIGH 7.5
- TI-2013-04289 The http-domino-enum-passwords.nse script in NMap before 6.40, when… CVSS 2.0MEDIUM 6.8
- TI-2017-13767 nse_libssh2.cc in Nmap 7.70 is subject to a denial of service condition due to a double… CVSS 3.0HIGH 7.5
- TI-2026-00008 Protection mechanism failure in Google Android CVSS 3.1HIGH 8.4
Sources
- CVE-2018-1000161 · CVE Program
- CVE-2018-1000161 · NVD
- FIRST EPSS
- GHSA-463f-727w-pqp7 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000161 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences