LightSAML version prior to 1.3.5 contains a Incorrect Access Control vulnerability in…
Priority LOW 35CWE-732Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
LightSAML version prior to 1.3.5 contains a Incorrect Access Control vulnerability in signature validation in readers in src/LightSaml/Model/XmlDSig/ that can result in impersonation of any user from Identity Provider. This vulnerability appears to have been fixed in 1.3.5 and later.
Why it matters now
EPSS 0.01224 68th percentileScored 2026-11-07
Fix Fixed lightsaml/lightsaml (Packagist): 1.3.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | lightsaml/lightsaml (Packagist) | before 1.3.5 | 1.3.5 | Patch available | GHSA-vg4f-8v9q-5c3x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- lightsaml/lightsaml (Packagist) Vendor— Affected before 1.3.5 Fixed in 1.3.5 Patch available GHSA-vg4f-8v9q-5c3x
Remediation
- Fix · GHSA-vg4f-8v9q-5c3x lightsaml/lightsaml (Packagist) Fixed in 1.3.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000165
- 2026-10-03 Alias added: GHSA-vg4f-8v9q-5c3x
References
Sources
- CVE-2018-1000165 · CVE Program
- CVE-2018-1000165 · NVD
- FIRST EPSS
- GHSA-vg4f-8v9q-5c3x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences