OISF suricata-update version 1.0.0a1 contains an Insecure Deserialization vulnerability…
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
OISF suricata-update version 1.0.0a1 contains an Insecure Deserialization vulnerability in the insecure yaml.load-Function as used in the following files: config.py:136, config.py:142, sources.py:99 and sources.py:131. The "list-sources"-command is affected by this bug. that can result in Remote Code Execution(even as root if suricata-update is called by root). This attack appears to be exploitable via a specially crafted yaml-file at https://www.openinfosecfoundation.org/rules/index.yaml. This vulnerability appears to have been fixed in 1.0.0b1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | suricata-update (PyPI) | before 1.0.0b1 | 1.0.0b1 | Patch available | GHSA-7c4h-w765-6pwg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- suricata-update (PyPI) Vendor— Affected before 1.0.0b1 Fixed in 1.0.0b1 Patch available GHSA-7c4h-w765-6pwg
Remediation
- Fix · GHSA-7c4h-w765-6pwg suricata-update (PyPI) Fixed in 1.0.0b1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000167
- 2026-10-03 Alias added: GHSA-7c4h-w765-6pwg
References
Advisory 2
Sources
- CVE-2018-1000167 · CVE Program
- CVE-2018-1000167 · NVD
- FIRST EPSS
- GHSA-7c4h-w765-6pwg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences