A cross-site scripting vulnerability exists in Jenkins S3 Plugin 0.10.12 and older in…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A cross-site scripting vulnerability exists in Jenkins S3 Plugin 0.10.12 and older in src/main/resources/hudson/plugins/s3/S3ArtifactsProjectAction/jobMain.jelly that allows attackers able to control file names of uploaded files to define file names containing JavaScript that would be executed in another user's browser when that user performs some UI actions.
Why it matters now
EPSS 0.00661 51st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:s3 (Maven): 0.11.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:s3 (Maven) | before 0.11.0 | 0.11.0 | Patch available | GHSA-3892-qqv6-h2qm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:s3 (Maven) Vendor— Affected before 0.11.0 Fixed in 0.11.0 Patch available GHSA-3892-qqv6-h2qm
Remediation
- Fix · GHSA-3892-qqv6-h2qm org.jenkins-ci.plugins:s3 (Maven) Fixed in 0.11.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000177
- 2026-10-03 Alias added: GHSA-3892-qqv6-h2qm
References
More Jenkins S3 Publisher vulnerabilities
- TI-2020-01991 Insufficiently protected credentials in Jenkins S3 publisher Plugin CVSS 3.1HIGH 7.5
- TI-2021-04731 Missing authorization in Jenkins S3 publisher Plugin CVSS 3.1MEDIUM 4.3
- TI-2021-04730 Missing authorization in Jenkins S3 publisher Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2018-1000177 · CVE Program
- CVE-2018-1000177 · NVD
- FIRST EPSS
- GHSA-3892-qqv6-h2qm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences