A server-side request forgery vulnerability exists in Jenkins CAS Plugin 1.4.1 and older…
Priority LOW 25CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
A server-side request forgery vulnerability exists in Jenkins CAS Plugin 1.4.1 and older in CasSecurityRealm.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL.
Why it matters now
EPSS 0.00608 49th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:cas-plugin (Maven): 1.4.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:cas-plugin (Maven) | before 1.4.2 | 1.4.2 | Patch available | GHSA-f8r7-7hv9-7f43 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:cas-plugin (Maven) Vendor— Affected before 1.4.2 Fixed in 1.4.2 Patch available GHSA-f8r7-7hv9-7f43
Remediation
- Fix · GHSA-f8r7-7hv9-7f43 org.jenkins-ci.plugins:cas-plugin (Maven) Fixed in 1.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000188
- 2026-10-03 Alias added: GHSA-f8r7-7hv9-7f43
References
More Jenkins Cas vulnerabilities
- TI-2023-16185 Jenkins CAS Plugin 1.6.2 and earlier does not invalidate the previous session on login. CVSS 3.1HIGH 8.8
- TI-2021-04753 Open redirect in Jenkins CAS Plugin CVSS 3.1MEDIUM 6.1
Sources
- CVE-2018-1000188 · CVE Program
- CVE-2018-1000188 · NVD
- FIRST EPSS
- GHSA-f8r7-7hv9-7f43 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences