A information exposure vulnerability exists in Jenkins 2.120 and older, LTS 2.107.2 and…
Priority LOW 22CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
A information exposure vulnerability exists in Jenkins 2.120 and older, LTS 2.107.2 and older in AboutJenkins.java, ListPluginsCommand.java that allows users with Overall/Read access to enumerate all installed plugins.
Why it matters now
EPSS 0.01098 65th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.107.3, 2.121Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.107.3 | 2.107.3 | Patch available | GHSA-2w4x-rxp7-grg7 |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.108 to before 2.121 | 2.121 | Patch available | GHSA-2w4x-rxp7-grg7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.107.3 Fixed in 2.107.3 Patch available GHSA-2w4x-rxp7-grg7
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.108 to before 2.121 Fixed in 2.121 Patch available GHSA-2w4x-rxp7-grg7
CPE configurations NVD · 3
Remediation
- Fix · GHSA-2w4x-rxp7-grg7 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.107.3 Advisory →
- Fix · GHSA-2w4x-rxp7-grg7 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.121 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000192
- 2026-10-03 Alias added: GHSA-2w4x-rxp7-grg7
References
Advisory 2
Sources
- CVE-2018-1000192 · CVE Program
- CVE-2018-1000192 · NVD
- FIRST EPSS
- GHSA-2w4x-rxp7-grg7 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000192 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences