Read the docs

A persisted cross-site scripting vulnerability exists in Jenkins Groovy Postbuild Plugin…

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A persisted cross-site scripting vulnerability exists in Jenkins Groovy Postbuild Plugin 2.3.1 and older in various Jelly files that allows attackers able to control build badge content to define JavaScript that would be executed in another user's browser when that other user performs some UI actions.

Why it matters now

EPSS 0.00719 54th percentileScored 2026-11-07
Fix Fixed org.jvnet.hudson.plugins:groovy-postbuild (Maven): 2.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jvnet.hudson.plugins:groovy-postbuild (Maven)before 2.42.4Patch availableGHSA-38ch-x695-m794
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jvnet.hudson.plugins:groovy-postbuild (Maven) Vendor— Affected before 2.4 Fixed in 2.4 Patch available GHSA-38ch-x695-m794

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:groovy_postbuild:*:*:*:*:*:jenkins:*:*up to 2.3.1VulnerableJenkins
  • cpe:2.3:a:jenkins:groovy_postbuild:*:*:*:*:*:jenkins:*:* Versions up to 2.3.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-38ch-x695-m794 org.jvnet.hudson.plugins:groovy-postbuild (Maven) Fixed in 2.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000202
  2. 2026-10-03 Alias added: GHSA-38ch-x695-m794

References

Sources