MODX Revolution version <=2.6.4 contains a Incorrect Access Control vulnerability in…
Priority HIGH 67CWE-732Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
MODX Revolution version <=2.6.4 contains a Incorrect Access Control vulnerability in Filtering user parameters before passing them into phpthumb class that can result in Creating file with custom a filename and content. This attack appear to be exploitable via Web request. This vulnerability appears to have been fixed in commit 06bc94257408f6a575de20ddb955aca505ef6e68.
Why it matters now
EPSS 0.64088 99th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed modx/revolution (Packagist): 2.7.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | modx/revolution (Packagist) | before 2.7.0 | 2.7.0 | Patch available | GHSA-m899-6mh4-mpc5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- modx/revolution (Packagist) Vendor— Affected before 2.7.0 Fixed in 2.7.0 Patch available GHSA-m899-6mh4-mpc5
Remediation
- Fix · GHSA-m899-6mh4-mpc5 modx/revolution (Packagist) Fixed in 2.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000207
- 2026-10-03 Alias added: GHSA-m899-6mh4-mpc5
References
Exploit 2
More Modx Revolution vulnerabilities
- TI-2017-04994 setup/templates/findcore.php in MODX Revolution 2.5.4-pl and earlier allows remote… CVSS 3.1CRITICAL 9.8
- TI-2017-04991 setup/controllers/welcome.php in MODX Revolution 2.5.4-pl and earlier allows remote… CVSS 3.1CRITICAL 9.8
- TI-2020-15872 A XML External Entity (XXE) vulnerability was discovered in the modRestServiceRequest… CVSS 3.1CRITICAL 9.1
- TI-2017-06532 In MODX Revolution before 2.5.7, a user with file upload permissions is able to execute… CVSS 3.0HIGH 8.8
- TI-2017-04993 The (1) update and (2) package-installation features in MODX Revolution 2.5.4-pl and… CVSS 3.1HIGH 8.1
- TI-2017-04992 The (1) update and (2) package-installation features in MODX Revolution 2.5.4-pl and… CVSS 3.1HIGH 8.1
Sources
- CVE-2018-1000207 · CVE Program
- CVE-2018-1000207 · NVD
- FIRST EPSS
- GHSA-m899-6mh4-mpc5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences