pkgconf version 1.5.0 to 1.5.2 contains a Buffer Overflow vulnerability in dequote() that…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-119 and the CVSS impact.
Summary
pkgconf version 1.5.0 to 1.5.2 contains a Buffer Overflow vulnerability in dequote() that can result in dequote() function returns 1-byte allocation if initial length is 0, leading to buffer overflow. This attack appear to be exploitable via specially crafted .pc file. This vulnerability appears to have been fixed in 1.5.3.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000221
- 2026-10-03 Alias added: GHSA-x83w-rcx4-rx6c
References
More Pkgconf vulnerabilities
- TI-2023-09834 In pkgconf through 1.9.3, variable duplication can cause unbounded string expansion due… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2018-1000221 · CVE Program
- CVE-2018-1000221 · NVD
- FIRST EPSS
- GHSA-x83w-rcx4-rx6c · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000221 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences