Read the docs

Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a…

Priority LOW 34CWE-522Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.

Summary

Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodePipelineSCM.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.37 and later.

Why it matters now

EPSS 0.00339 27th percentileScored 2026-11-07
Fix Fixed com.amazonaws:aws-codepipeline (Maven): 0.37

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—com.amazonaws:aws-codepipeline (Maven)before 0.370.37Patch availableGHSA-5gwq-4275-q4qc
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • com.amazonaws:aws-codepipeline (Maven) Vendor— Affected before 0.37 Fixed in 0.37 Patch available GHSA-5gwq-4275-q4qc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:aws_codepipeline:*:*:*:*:*:jenkins:*:*up to 0.36VulnerableJenkins
  • cpe:2.3:a:jenkins:aws_codepipeline:*:*:*:*:*:jenkins:*:* Versions up to 0.36 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-5gwq-4275-q4qc com.amazonaws:aws-codepipeline (Maven) Fixed in 0.37 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000401
  2. 2026-10-03 Alias added: GHSA-5gwq-4275-q4qc

References

Sources