A cross-site scripting vulnerability exists in Jenkins Rebuilder Plugin 1.28 and earlier…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A cross-site scripting vulnerability exists in Jenkins Rebuilder Plugin 1.28 and earlier in RebuildAction/BooleanParameterValue.jelly, RebuildAction/ExtendedChoiceParameterValue.jelly, RebuildAction/FileParameterValue.jelly, RebuildAction/LabelParameterValue.jelly, RebuildAction/ListSubversionTagsParameterValue.jelly, RebuildAction/MavenMetadataParameterValue.jelly, RebuildAction/NodeParameterValue.jelly, RebuildAction/PasswordParameterValue.jelly, RebuildAction/RandomStringParameterValue.jelly, RebuildAction/RunParameterValue.jelly, RebuildAction/StringParameterValue.jelly, RebuildAction/TextParameterValue.jelly, RebuildAction/ValidatingStringParameterValue.jelly that allows users with Job/Configuration permission to insert arbitrary HTML into rebuild forms.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | com.sonyericsson.hudson.plugins.rebuild:rebuild (Maven) | before 1.29 | 1.29 | Patch available | GHSA-7m8v-w6f9-q2f9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- com.sonyericsson.hudson.plugins.rebuild:rebuild (Maven) Vendor— Affected before 1.29 Fixed in 1.29 Patch available GHSA-7m8v-w6f9-q2f9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rebuild_project:rebuild:*:*:*:*:*:jenkins:*:* | up to 1.28 | Vulnerable | Rebuild Project |
- cpe:2.3:a:rebuild_project:rebuild:*:*:*:*:*:jenkins:*:* Versions up to 1.28 Vulnerable ·Rebuild Project
Remediation
- Fix · GHSA-7m8v-w6f9-q2f9 com.sonyericsson.hudson.plugins.rebuild:rebuild (Maven) Fixed in 1.29 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000415
- 2026-10-03 Alias added: GHSA-7m8v-w6f9-q2f9
- 2026-11-07 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2018-1000415 · CVE Program
- CVE-2018-1000415 · NVD
- FIRST EPSS
- GHSA-7m8v-w6f9-q2f9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences