A reflected cross-site scripting vulnerability exists in Jenkins Job Config History…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A reflected cross-site scripting vulnerability exists in Jenkins Job Config History Plugin 2.18 and earlier in all Jelly files that shows arbitrary attacker-specified HTML in Jenkins to users with Job/Configure access.
Why it matters now
EPSS 0.00842 58th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:jobConfigHistory (Maven): 2.18.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:jobConfigHistory (Maven) | before 2.18.1 | 2.18.1 | Patch available | GHSA-w3r4-vx9w-f7p7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:jobConfigHistory (Maven) Vendor— Affected before 2.18.1 Fixed in 2.18.1 Patch available GHSA-w3r4-vx9w-f7p7
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jobconfighistory_project:jobconfighistory:*:*:*:*:*:jenkins:*:* | up to 2.18 | Vulnerable | Jobconfighistory Project |
- cpe:2.3:a:jobconfighistory_project:jobconfighistory:*:*:*:*:*:jenkins:*:* Versions up to 2.18 Vulnerable ·Jobconfighistory Project
Remediation
- Fix · GHSA-w3r4-vx9w-f7p7 org.jenkins-ci.plugins:jobConfigHistory (Maven) Fixed in 2.18.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000416
- 2026-10-03 Alias added: GHSA-w3r4-vx9w-f7p7
References
Sources
- CVE-2018-1000416 · CVE Program
- CVE-2018-1000416 · NVD
- FIRST EPSS
- GHSA-w3r4-vx9w-f7p7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences