An improper authorization vulnerability exists in Jenkins HipChat Plugin 2.2.0 and…
Priority LOW 32Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
An improper authorization vulnerability exists in Jenkins HipChat Plugin 2.2.0 and earlier in HipChatNotifier.java that allows attackers with Overall/Read access to obtain credentials IDs for credentials stored in Jenkins.
Why it matters now
EPSS 0.01641 76th percentileScored 2026-11-07
Fix Fixed org.jvnet.hudson.plugins:hipchat (Maven): 2.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jvnet.hudson.plugins:hipchat (Maven) | before 2.2.1 | 2.2.1 | Patch available | GHSA-798p-53r7-mgw9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jvnet.hudson.plugins:hipchat (Maven) Vendor— Affected before 2.2.1 Fixed in 2.2.1 Patch available GHSA-798p-53r7-mgw9
Remediation
- Fix · GHSA-798p-53r7-mgw9 org.jvnet.hudson.plugins:hipchat (Maven) Fixed in 2.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000419
- 2026-10-03 Alias added: GHSA-798p-53r7-mgw9
References
More Atlassian Hipchat vulnerabilities
- TI-2015-04722 The HipChat for JIRA plugin before 6.30.0 for Atlassian JIRA allows remote authenticated… CVSS 2.0MEDIUM 6.5
- TI-2017-10687 Memory corruption in Atlassian Hipchat for Mac desktop client CVSS 3.1CRITICAL 9.8
- TI-2018-15891 An improper authorization vulnerability exists in Jenkins HipChat Plugin 2.2.0 and… CVSS 3.0HIGH 8.8
- TI-2017-05648 Acceptance of invalid/self-signed TLS certificates in Atlassian HipChat before 3.16.2 for… CVSS 3.0MEDIUM 5.9
Sources
- CVE-2018-1000419 · CVE Program
- CVE-2018-1000419 · NVD
- FIRST EPSS
- GHSA-798p-53r7-mgw9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences