Read the docs

An insufficiently protected credentials vulnerability exists in Jenkins SonarQube Scanner…

Priority LOW 34CWE-522Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.

Summary

An insufficiently protected credentials vulnerability exists in Jenkins SonarQube Scanner Plugin 2.8 and earlier in SonarInstallation.java that allows attackers with local file system access to obtain the credentials used to connect to SonarQube.

Why it matters now

EPSS 0.00344 28th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:sonar (Maven): 2.8.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.plugins:sonar (Maven)before 2.8.12.8.1Patch availableGHSA-3ccq-gccx-pm7j
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:sonar (Maven) Vendor— Affected before 2.8.1 Fixed in 2.8.1 Patch available GHSA-3ccq-gccx-pm7j

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sonarsource:sonarqube_scanner:*:*:*:*:*:jenkins:*:*up to 2.8VulnerableSonarSource
  • cpe:2.3:a:sonarsource:sonarqube_scanner:*:*:*:*:*:jenkins:*:* Versions up to 2.8 Vulnerable ·SonarSource

Remediation

  • Fix · GHSA-3ccq-gccx-pm7j org.jenkins-ci.plugins:sonar (Maven) Fixed in 2.8.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000425
  2. 2026-10-03 Alias added: GHSA-3ccq-gccx-pm7j

References

Sources