A cross-site scripting vulnerability exists in Jenkins Git Changelog Plugin 2.6 and…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A cross-site scripting vulnerability exists in Jenkins Git Changelog Plugin 2.6 and earlier in GitChangelogSummaryDecorator/summary.jelly, GitChangelogLeftsideBuildDecorator/badge.jelly, GitLogJiraFilterPostPublisher/config.jelly, GitLogBasicChangelogPostPublisher/config.jelly that allows attackers able to control the Git history parsed by the plugin to have Jenkins render arbitrary HTML on some pages.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | de.wellnerbou.jenkins:git-changelog (Maven) | before 2.7 | 2.7 | Patch available | GHSA-jcmg-9rw5-9rm2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- de.wellnerbou.jenkins:git-changelog (Maven) Vendor— Affected before 2.7 Fixed in 2.7 Patch available GHSA-jcmg-9rw5-9rm2
Remediation
- Fix · GHSA-jcmg-9rw5-9rm2 de.wellnerbou.jenkins:git-changelog (Maven) Fixed in 2.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000426
- 2026-10-03 Alias added: GHSA-jcmg-9rw5-9rm2
References
More Jenkins Git Changelog vulnerabilities
- TI-2019-07723 Insufficiently protected credentials in Jenkins Git Changelog Plugin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2018-1000426 · CVE Program
- CVE-2018-1000426 · NVD
- FIRST EPSS
- GHSA-jcmg-9rw5-9rm2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences