Redirection version 2.7.1 contains a Serialisation vulnerability possibly allowing ACE…
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-502.
Summary
Redirection version 2.7.1 contains a Serialisation vulnerability possibly allowing ACE vulnerability in Settings page AJAX that can result in could allow admin to execute arbitrary code in some circumstances. This attack appear to be exploitable via Attacker must have access to admin account. This vulnerability appears to have been fixed in 2.8.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redirection:redirection:2.7.1:*:*:*:*:wordpress:*:* | 2.7.1 | Vulnerable | Redirection |
- cpe:2.3:a:redirection:redirection:2.7.1:*:*:*:*:wordpress:*:* Versions 2.7.1 Vulnerable ·Redirection
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000509
- 2026-10-03 Alias added: GHSA-f85q-26xg-xvqx
References
More Redirection vulnerabilities
- TI-2018-15904 Redirection version 2.7.3 contains a ACE via file inclusion vulnerability in Pass-through… CVSS 3.0HIGH 7.2
- TI-2012-05419 The redirection plugin before 2.2.12 for WordPress has XSS, a different issue than CVE-2011-4562. CVSS 3.0MEDIUM 6.1
- TI-2011-04601 The redirection plugin before 2.2.9 for WordPress has XSS in the admin menu, a different issue than CVE-2011-4562. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2018-1000509 · CVE Program
- CVE-2018-1000509 · NVD
- FIRST EPSS
- GHSA-f85q-26xg-xvqx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences