aaugustin websockets version 4 contains a CWE-409: Improper Handling of Highly Compressed…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
aaugustin websockets version 4 contains a CWE-409: Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Servers and clients, unless configured with compression=None that can result in Denial of Service by memory exhaustion. This attack appear to be exploitable via Sending a specially crafted frame on an established connection. This vulnerability appears to have been fixed in 5.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | websockets (PyPI) | 4.0 to before 5.0 | 5.0 | Patch available | GHSA-6g87-ff9q-v847 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- websockets (PyPI) Vendor— Affected 4.0 to before 5.0 Fixed in 5.0 Patch available GHSA-6g87-ff9q-v847
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:websockets_project:websockets:4.0:*:*:*:*:python:*:* | 4.0 | Vulnerable | Websockets Project |
- cpe:2.3:a:websockets_project:websockets:4.0:*:*:*:*:python:*:* Versions 4.0 Vulnerable ·Websockets Project
Remediation
- Fix · GHSA-6g87-ff9q-v847 websockets (PyPI) Fixed in 5.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000518
- 2026-10-03 Alias added: GHSA-6g87-ff9q-v847
References
More Websockets Project Websockets vulnerabilities
- TI-2021-13200 The aaugustin websockets library before 9.1 for Python has an Observable Timing… CVSS 3.1MEDIUM 5.9
Sources
- CVE-2018-1000518 · CVE Program
- CVE-2018-1000518 · NVD
- FIRST EPSS
- GHSA-6g87-ff9q-v847 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000518 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences