Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Grails Fields plugin version 2.2.7 contains a Cross Site Scripting (XSS) vulnerability in Using the display tag that can result in XSS . This vulnerability appears to have been fixed in 2.2.8.
Why it matters now
EPSS 0.01138 66th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.grails.plugins:fields (Maven): 2.2.8org.grails:grails-core (Maven): 3.3.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.grails.plugins:fields (Maven) | before 2.2.8 | 2.2.8 | Patch available | GHSA-q25j-gcmv-5qpp |
| — | org.grails:grails-core (Maven) | before 3.3.6 | 3.3.6 | Patch available | GHSA-q25j-gcmv-5qpp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.grails.plugins:fields (Maven) Vendor— Affected before 2.2.8 Fixed in 2.2.8 Patch available GHSA-q25j-gcmv-5qpp
- org.grails:grails-core (Maven) Vendor— Affected before 3.3.6 Fixed in 3.3.6 Patch available GHSA-q25j-gcmv-5qpp
Remediation
- Fix · GHSA-q25j-gcmv-5qpp org.grails.plugins:fields (Maven) Fixed in 2.2.8 Advisory →
- Fix · GHSA-q25j-gcmv-5qpp org.grails:grails-core (Maven) Fixed in 3.3.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000529
- 2026-10-03 Alias added: GHSA-q25j-gcmv-5qpp
References
Sources
- CVE-2018-1000529 · CVE Program
- CVE-2018-1000529 · NVD
- FIRST EPSS
- GHSA-q25j-gcmv-5qpp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences