rubyzip gem rubyzip version 1.2.1 and earlier contains a Directory Traversal…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-434.
Summary
rubyzip gem rubyzip version 1.2.1 and earlier contains a Directory Traversal vulnerability in Zip::File component that can result in write arbitrary files to the filesystem. This attack appear to be exploitable via If a site allows uploading of .zip files , an attacker can upload a malicious file that contains symlinks or files with absolute pathnames "../" to write arbitrary files to the filesystem..
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | rubyzip (RubyGems) | before 1.2.2 | 1.2.2 | Patch available | GHSA-vqcq-mrmw-mcmg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- rubyzip (RubyGems) Vendor— Affected before 1.2.2 Fixed in 1.2.2 Patch available GHSA-vqcq-mrmw-mcmg
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyzip_project:rubyzip:*:*:*:*:*:*:*:* | up to 1.2.1 | Vulnerable | Rubyzip Project |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:a:redhat:cloudforms:4.6:*:*:*:*:*:*:* | 4.6 | Vulnerable | Red Hat |
- cpe:2.3:a:rubyzip_project:rubyzip:*:*:*:*:*:*:*:* Versions up to 1.2.1 Vulnerable ·Rubyzip Project
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:a:redhat:cloudforms:4.6:*:*:*:*:*:*:* Versions 4.6 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-vqcq-mrmw-mcmg rubyzip (RubyGems) Fixed in 1.2.2 Advisory →
Red Hat 1 advisory
- RHSA-2018:3466 Released 2018-11-05 · Red Hat rating ModerateCloudForms 4.6.5 security, bug fix and enhancement update
- CloudForms Management Engine 5.9 ansible-tower-3.2.7-1.el7at, ansible-tower-server-3.2.7-1.el7at, ansible-tower-setup-3.2.7-1.el7at +9
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Quickstart Cloud Installer 1 | Affected | No fix planned: Will not fix |
| CloudForms Management Engine 5.9 | Fixed | RHSA-2018:3466 |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000544
- 2026-10-03 Alias added: GHSA-vqcq-mrmw-mcmg
References
Advisory 4
Sources
- CVE-2018-1000544 · CVE Program
- CVE-2018-1000544 · NVD
- FIRST EPSS
- GHSA-vqcq-mrmw-mcmg · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000544 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences