A arbitrary file read vulnerability exists in Jenkins SSH Credentials Plugin 1.13 and…
Priority LOW 31CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
A arbitrary file read vulnerability exists in Jenkins SSH Credentials Plugin 1.13 and earlier in BasicSSHUserPrivateKey.java that allows attackers with a Jenkins account and the permission to configure credential bindings to read arbitrary files from the Jenkins master file system.
Why it matters now
EPSS 0.01013 63rd percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins:ssh-credentials (Maven): 1.14org.jenkins-ci.plugins:credentials (Maven): 2.1.17Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:ssh-credentials (Maven) | before 1.14 | 1.14 | Patch available | GHSA-cwcf-5m5w-mq2w |
| — | org.jenkins-ci.plugins:credentials (Maven) | before 2.1.17 | 2.1.17 | Patch available | GHSA-cwcf-5m5w-mq2w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:ssh-credentials (Maven) Vendor— Affected before 1.14 Fixed in 1.14 Patch available GHSA-cwcf-5m5w-mq2w
- org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected before 2.1.17 Fixed in 2.1.17 Patch available GHSA-cwcf-5m5w-mq2w
Remediation
- Fix · GHSA-cwcf-5m5w-mq2w org.jenkins-ci.plugins:ssh-credentials (Maven) Fixed in 1.14 Advisory →
- Fix · GHSA-cwcf-5m5w-mq2w org.jenkins-ci.plugins:credentials (Maven) Fixed in 2.1.17 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000601
- 2026-10-03 Alias added: GHSA-cwcf-5m5w-mq2w
References
Advisory 2
Other 4
- https://github.com/jenkinsci/credentials-plugin/commit/23fbd6de33cc3cb74eafd44e7b27dd87b52c8904
- https://github.com/jenkinsci/ssh-credentials-plugin/commit/18b3121fa94a174064447d637dc11539e33b3a76
- https://github.com/jenkinsci/ssh-credentials-plugin
- https://github.com/jenkinsci/ssh-credentials-plugin/commits/ssh-credentials-1.14
Sources
- CVE-2018-1000601 · CVE Program
- CVE-2018-1000601 · NVD
- FIRST EPSS
- GHSA-cwcf-5m5w-mq2w · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000601 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences