The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 fixed, 4 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Flask (PyPI) | before 0.12.3 | 0.12.3 | Patch available | GHSA-562c-5r94-xh97 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Flask (PyPI) Vendor— Affected before 0.12.3 Fixed in 0.12.3 Patch available GHSA-562c-5r94-xh97
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:palletsprojects:flask:*:*:*:*:*:*:*:* | before 0.12.3 | Vulnerable | pallets |
| cpe:2.3:a:netapp:active_iq:*:*:*:*:*:*:*:* | all versions | Vulnerable | NetApp |
| cpe:2.3:a:netapp:hyper_converged_infrastructure:*:*:*:*:*:*:*:* | all versions | Vulnerable | NetApp |
| cpe:2.3:a:netapp:ontap_select_deploy_utility:*:*:*:*:*:*:*:* | all versions | Vulnerable | NetApp |
- cpe:2.3:a:palletsprojects:flask:*:*:*:*:*:*:*:* Versions before 0.12.3 Vulnerable ·pallets
- cpe:2.3:a:netapp:active_iq:*:*:*:*:*:*:*:* Versions all versions Vulnerable ·NetApp
- cpe:2.3:a:netapp:hyper_converged_infrastructure:*:*:*:*:*:*:*:* Versions all versions Vulnerable ·NetApp
- cpe:2.3:a:netapp:ontap_select_deploy_utility:*:*:*:*:*:*:*:* Versions all versions Vulnerable ·NetApp
Remediation
- Fix · GHSA-562c-5r94-xh97 Flask (PyPI) Fixed in 0.12.3 Advisory →
Red Hat 1 advisory
- RHSA-2020:0870 Released 2020-03-17 · Red Hat rating Lowpython-flask security update
- Red Hat Enterprise Linux 7 Extras python-flask-1:0.10.1-5.el7_7
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 2 | Affected | No fix yet |
| Red Hat Ceph Storage 3 | Affected | No fix yet: Fix deferred |
| Red Hat Storage 3 | Affected | No fix yet: Fix deferred |
| Red Hat Update Infrastructure 3 for Cloud Providers | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 7 Extras | Fixed | RHSA-2020:0870 |
Not affected: 3 products
- Red Hat Ceph Storage 7
- Red Hat Enterprise Linux 8
- Red Hat Satellite 6
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000656
- 2026-10-03 Alias added: GHSA-562c-5r94-xh97
- 2026-10-16 EPSS moved to the 90th–95th percentile
References
Patch 2
Advisory 4
Other 6
- [debian-lts-announce] 20190820 [SECURITY] [DLA 1892-1] flask security update
- https://github.com/pallets/flask/commit/b178e89e4456e777b1a7ac6d7199052d0dfdbbbe
- https://github.com/pallets/flask
- https://github.com/pypa/advisory-database/tree/main/vulns/flask/PYSEC-2018-66.yaml
- https://security.netapp.com/advisory/ntap-20190221-0001
- https://usn.ubuntu.com/4378-1
Sources
- CVE-2018-1000656 · CVE Program
- CVE-2018-1000656 · NVD
- FIRST EPSS
- GHSA-562c-5r94-xh97 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000656 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences