jsish version 2.4.67 contains a CWE-476: NULL Pointer Dereference vulnerability in…
Priority LOW 30CWE-476Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-476.
Summary
jsish version 2.4.67 contains a CWE-476: NULL Pointer Dereference vulnerability in Jsi_LogMsg (jsiUtils.c:196) that can result in Crash due to segmentation fault. This attack appear to be exploitable via the victim executing specially crafted javascript code. This vulnerability appears to have been fixed in 2.4.69.
Why it matters now
EPSS 0.00856 58th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000661
- 2026-10-03 Alias added: GHSA-r435-g2mc-22v9
References
More Jsish vulnerabilities
- TI-2025-40399 A type confusion in jsish 2.0 allows incorrect control flow during execution of the… CVSS 3.1CRITICAL 9.8
- TI-2024-16031 Jsish v3.5.0 (commit 42c694c) was discovered to contain a stack-overflow via the… CVSS 3.1CRITICAL 9.8
- TI-2024-16033 Jsish v3.5.0 (commit 42c694c) was discovered to contain a use-after-free via the SplitChar at ./src/jsiUtils.c. CVSS 3.1CRITICAL 9.8
- TI-2020-14504 An issue found in Jsish v.3.0.11 and before allows an attacker to cause a denial of… CVSS 3.1HIGH 7.5
- TI-2024-16032 Jsish v3.5.0 was discovered to contain a heap-buffer-overflow in ./src/jsiUtils.c. CVSS 3.1CRITICAL 9.8
- TI-2020-14415 Integer overflow vulnerability in function Jsi_ObjSetLength in jsish before 3.0.6, allows… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2018-1000661 · CVE Program
- CVE-2018-1000661 · NVD
- FIRST EPSS
- GHSA-r435-g2mc-22v9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences