Read the docs

jsish version 2.4.70 2.047 contains a CWE-125: Out-of-bounds Read vulnerability in…

Priority LOW 30CWE-125Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-125 and the CVSS impact.

Summary

jsish version 2.4.70 2.047 contains a CWE-125: Out-of-bounds Read vulnerability in function jsi_ObjArrayLookup (jsiObj.c:274) that can result in Crash due to segmentation fault. This attack appear to be exploitable via The victim must execute crafted javascript code. This vulnerability appears to have been fixed in 2.4.71.

Why it matters now

EPSS 0.00856 58th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jsish:jsish:2.4.70_2.047:*:*:*:*:*:*:*2.4.70_2.047VulnerableJsish
  • cpe:2.3:a:jsish:jsish:2.4.70_2.047:*:*:*:*:*:*:* Versions 2.4.70_2.047 Vulnerable ·Jsish

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000668
  2. 2026-10-03 Alias added: GHSA-62rf-g5f7-frmw

References

  • TI-2025-40399 A type confusion in jsish 2.0 allows incorrect control flow during execution of the… CVSS 3.1CRITICAL 9.8
  • TI-2024-16031 Jsish v3.5.0 (commit 42c694c) was discovered to contain a stack-overflow via the… CVSS 3.1CRITICAL 9.8
  • TI-2024-16033 Jsish v3.5.0 (commit 42c694c) was discovered to contain a use-after-free via the SplitChar at ./src/jsiUtils.c. CVSS 3.1CRITICAL 9.8
  • TI-2020-14504 An issue found in Jsish v.3.0.11 and before allows an attacker to cause a denial of… CVSS 3.1HIGH 7.5
  • TI-2024-16032 Jsish v3.5.0 was discovered to contain a heap-buffer-overflow in ./src/jsiUtils.c. CVSS 3.1CRITICAL 9.8
  • TI-2020-14415 Integer overflow vulnerability in function Jsi_ObjSetLength in jsish before 3.0.6, allows… CVSS 3.1CRITICAL 9.8
See all 52 →

Sources