Read the docs

KOHA Library System version 16.11.x (up until 16.11.13) and 17.05.x (up until 17.05.05)…

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

KOHA Library System version 16.11.x (up until 16.11.13) and 17.05.x (up until 17.05.05) contains a Cross Site Scripting (XSS) vulnerability in Multiple fields on multiple pages including /cgi-bin/koha/acqui/supplier.pl?op=enter , /cgi-bin/koha/circ/circulation.pl?borrowernumber=[number] , /cgi-bin/koha/serials/subscription-add.pl that can result in Privilege escalation by taking control of higher privileged users browser sessions. This attack appear to be exploitable via Victims must be socially engineered to visit a vulnerable webpage containing malicious payload. This vulnerability appears to have been fixed in 17.11.

Why it matters now

EPSS 0.00648 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:koha:koha:*:*:*:*:*:*:*:*16.11.0 – 16.11.13; 17.05.0 – 17.05.05VulnerableKoha
  • cpe:2.3:a:koha:koha:*:*:*:*:*:*:*:* Versions 16.11.0 – 16.11.13; 17.05.0 – 17.05.05 Vulnerable ·Koha

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000670
  2. 2026-10-03 Alias added: GHSA-jmgp-hv54-4jff
  3. 2026-10-16 EPSS moved to the 50th–90th percentile

References

  • TI-2024-18975 An issue in Koha ILS 23.05 and before allows a remote attacker to execute arbitrary code… CVSS 3.1CRITICAL 9.6
  • TI-2024-18976 Cross Site Scripting vulnerability in Koha ILS 23.05 and before allows a remote attacker… CVSS 3.1CRITICAL 9.6
  • TI-2026-24397 Authenticated SQL Injection in Koha displayby parameter of suggestion.pl CVSS 4.0HIGH 8.7
  • TI-2024-16095 CSV Injection vulnerability in '/members/moremember.pl' and '/admin/aqbudgets.pl'… CVSS 3.1HIGH 8.8
  • TI-2026-21318 Koha versions up to 25.11 contain a Server-Side Request Forgery (SSRF) vulnerability via… CVSS 3.1MEDIUM 6.5
  • TI-2015-03876 Multiple directory traversal vulnerabilities in Koha 3.14.x before 3.14.16, 3.16.x before… CVSS 3.0HIGH 7.5
See all 23 →

Sources