Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-416 and the CVSS impact.
Summary
Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pyopenssl (PyPI) | before 17.5.0 | 17.5.0 | Patch available | GHSA-p28m-34f6-967q |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pyopenssl (PyPI) Vendor— Affected before 17.5.0 Fixed in 17.5.0 Patch available GHSA-p28m-34f6-967q
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pyopenssl:pyopenssl:*:*:*:*:*:*:*:* | before 17.5.0 | Vulnerable | Pyopenssl |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:* | 13 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
- cpe:2.3:a:pyopenssl:pyopenssl:*:*:*:*:*:*:*:* Versions before 17.5.0 Vulnerable ·Pyopenssl
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:* Versions 13 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-p28m-34f6-967q pyopenssl (PyPI) Fixed in 17.5.0 Advisory →
Red Hat 1 advisory
- RHSA-2019:0085 Released 2019-01-16 · Red Hat rating ModeratepyOpenSSL security and bug fix update
- Red Hat OpenStack Platform 13.0 pyOpenSSL-17.5.0-1.el7ost, python2-pyOpenSSL-17.5.0-1.el7ost
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 12 (Pike) | Affected | No fix planned: Will not fix |
| Red Hat Storage 3 | Affected | No fix planned: Will not fix |
| Red Hat Virtualization 4 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 13.0 | Fixed | RHSA-2019:0085 |
Not affected: 5 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat OpenStack Platform 14 (Rocky)
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000807
- 2026-10-03 Alias added: GHSA-p28m-34f6-967q
References
Advisory 4
Sources
- CVE-2018-1000807 · CVE Program
- CVE-2018-1000807 · NVD
- FIRST EPSS
- GHSA-p28m-34f6-967q · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000807 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences